undefined reference to `dlopen@GLIBC_2.34'
It is reported by some users that they cannot run SaxonC on some Debian systems without upgrading the default glibc version.
Some users state that they are running GLIBC 2.32 and also 2.31
It should be possible to build the SaxonC distribution produced by Graalvm on machines with older version of GLIBC.
Updated by O'Neil Delpratt 6 months ago
- Status changed from New to In Progress
- % Done changed from 0 to 100
We have patched this in the build process by building the SaxonC distribution on an older release of GLIBC in a docker container. Preliminary C++ tests done.
objdump -p libs/nix/libsaxon-eec-12.2.so
Version References: required from librt.so.1: 0x09691a75 0x00 13 GLIBC_2.2.5 required from libdl.so.2: 0x09691a75 0x00 08 GLIBC_2.2.5 required from libstdc++.so.6: 0x08922974 0x00 04 GLIBCXX_3.4 required from libpthread.so.0: 0x09691973 0x00 11 GLIBC_2.3.3 0x09691972 0x00 06 GLIBC_2.3.2 0x06969192 0x00 05 GLIBC_2.12 0x09691a75 0x00 03 GLIBC_2.2.5 required from libc.so.6: 0x06969194 0x00 14 GLIBC_2.14 0x0d696916 0x00 12 GLIBC_2.6 0x0d696914 0x00 10 GLIBC_2.4 0x09691974 0x00 09 GLIBC_2.3.4 0x0d696913 0x00 07 GLIBC_2.3 0x09691a75 0x00 02 GLIBC_2.2.5
Updated by O'Neil Delpratt 5 months ago
- Priority changed from Low to Normal
Tests completed for this patch. Marking this bug as resolved.
At the time of the maintenance release we need to update the documentation to remove limitation on GLIBC on page https://www.saxonica.com/saxon-c/documentation12/index.html#!starting/installing/installingLinux Remove the text:
As a prerequisite SaxonC requires GLIBC_2.32 as minimum. Note that on some Debian stable releases this version of the C library is not available: installing the library package libc6 should resolve any compile issues.
Please register to edit this issue