Project

Profile

Help

Bug #2332

closed

Saxon Configuration: Schema

Added by Andreas Saremba over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
Documentation
Sprint/Milestone:
Start date:
2015-03-19
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
9.6
Fix Committed on Branch:
9.6
Fixed in Maintenance Release:
Platforms:

Description

The documentation for the xslt element in the Saxon configuration says (in http://www.saxonica.com/html/documentation/configuration/configuration-file/config-xslt.html): "The xslt element +may+ contain one or more extensionElement children ...".

But in the schema config.xsd, extensionElement is not optional.

As far as I can judge, this does not cause an error, but it is slightly irritating. Is extensionElement really meant to be mandatory?

This is what I use: - marked as invalid in OxygenXML.

Actions #1

Updated by Michael Kay over 7 years ago

  • Assignee set to Debbie Lockett
Actions #2

Updated by Debbie Lockett over 7 years ago

Indeed extensionElement children are optional, the schema needs correcting. To fix config.xsd for this issue you could replace <xs:element ref="c:extensionElement"/> with <xs:element ref="c:extensionElement" minOccurs="0" maxOccurs="unbounded"/> on line 331 (i.e. inside the definition of the xslt element).

We've actually just been made aware of the fact that config.xsd is out of date, and there's another bug open (#2329) to make corrections to config.xsd and to get the corresponding documentation up to date.

Actions #3

Updated by Debbie Lockett over 7 years ago

  • Status changed from New to Resolved

The schema has been corrected for this issue, along with a number of other updates. See the resolved bug #2329 - where the up to date file is attached (note that the saxon-resources download is only updated for major releases).

Actions #4

Updated by O'Neil Delpratt over 7 years ago

  • Status changed from Resolved to In Progress
  • Assignee changed from Debbie Lockett to O'Neil Delpratt
  • Priority changed from Low to Normal
  • % Done changed from 0 to 50
  • Found in version set to 9.6
  • Fixed in version set to 9.6.0.5

Bug fix applied in the Saxon 9.6.0.5 maintenance release, but the saxon resources file has not been applied with the fix, therefore I am marking this as in-progress so that we don't lose track of it.

Actions #5

Updated by O'Neil Delpratt over 7 years ago

  • Status changed from In Progress to Closed
  • Assignee changed from O'Neil Delpratt to Debbie Lockett
  • % Done changed from 50 to 100

Th updated Saxon resources file has now been uploaded to the Saxon website. Bug issue now closed.

Actions #6

Updated by O'Neil Delpratt over 6 years ago

  • Sprint/Milestone set to 9.6.0.5
  • Applies to branch 9.6 added
  • Fix Committed on Branch 9.6 added
  • Fixed in Maintenance Release 9.6.0.5 added

Please register to edit this issue

Also available in: Atom PDF