Project

Profile

Help

Bug #4410

closed

Error: MyClassInDll.setBaseURI not found

Added by O'Neil Delpratt over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
C++ API
Start date:
2019-12-17
Due date:
% Done:

100%

Estimated time:
Found in version:
1.2.1
Fixed in version:
11.1
Platforms:

Description

Reported here: https://saxonica.plan.io/boards/4/topics/7728

The call to the setBaseURI method in the C++ class XPathProcessor gives the error:

Error: MyClassInDll.setBaseURI not found
Actions #1

Updated by O'Neil Delpratt over 4 years ago

  • Status changed from New to Resolved

Bug fixed and will be available in the next maintenance release.

The issue is we have incorrect method signature used in the JNI.

The setBaseURI is a void method, but we have it as returning a boolean:

(jmethodID) SaxonProcessor::sxn_environ->env->GetMethodID(cppClass, "setBaseURI",
				"(Ljava/lang/String;)Z");

Should be changed to:

(jmethodID) SaxonProcessor::sxn_environ->env->GetMethodID(cppClass, "setBaseURI",
				"(Ljava/lang/String;)V");

the workaround fix is to apply the simple fix in the C++ XPathProcessor.cpp file.

Actions #2

Updated by O'Neil Delpratt over 2 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in version set to 11.1

Bug fix patched in SaxonC 11.1 release

Please register to edit this issue

Also available in: Atom PDF