Project

Profile

Help

Bug #4859

closed

Jet Runtime Has detected Unrecoverable Error-libsaxonhec.dll transformToString not found

Added by Brian Higashide over 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
High
Category:
Python
Start date:
2020-12-17
Due date:
% Done:

0%

Estimated time:
Found in version:
1.2.1
Fixed in version:
Platforms:

Description

When trying to run the following code, i am getting this error:

Error: C:\Program Files\Saxonica\SaxonHEC1.2.1\libsaxonhec.dlltransformToString not found

12072020

JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR: system exception at 0x00007fffed7d0a68

print(fcfilename)
proc=saxonc.PySaxonProcessor(license=False)
print('Test Saxon/C on Python')
print(proc.version)
xslt30_processor = proc.new_xslt30_processor()
xslt30_processor.set_cwd(".")
	transform=xslt30_processor.transform_to_string(source_file="S:/QA/Projects2/SBE/schematron/NJFC_0814_22000040437.xml",stylesheet_file='S:/QA/Projects2/SBE/schematron/AccountTransfer-runtime-compiled.xsl',output_file='S:/QA/Projects2/SBE/schematron/testresults.xml')

	msg=xslt30_processor.get_xsl_messages()
	print(fcfilename)
	printed=[]
	if msg is not None:
		i=0
		while i <msg.size:
			if str(msg.item_at(i)) not in printed:
				print('\t'+msg.item_at(i))
				printed.append(str(msg.item_at(i)))

Files

jet_err_5828.txt (44.9 KB) jet_err_5828.txt Brian Higashide, 2020-12-17 15:06
jet_dump_5828.dmp (169 MB) jet_dump_5828.dmp Brian Higashide, 2020-12-17 15:06
clipboard-202012180939-zcvqr.png (25.1 KB) clipboard-202012180939-zcvqr.png Brian Higashide, 2020-12-18 15:39
jet_err_14200.txt (39.3 KB) jet_err_14200.txt Brian Higashide, 2020-12-19 07:03
jet_dump_14200.dmp (169 MB) jet_dump_14200.dmp Brian Higashide, 2020-12-19 07:04

Related issues

Is duplicate of SaxonC - Bug #4847: sotransformToString - PythonClosedO'Neil Delpratt2020-12-02

Actions

Please register to edit this issue

Also available in: Atom PDF