Project

Profile

Help

Bug #5330

closed

libsaxon-HEC-11.1/samples/php/query is empty for Linux

Added by Martin Honnen about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Samples
Start date:
2022-02-16
Due date:
% Done:

100%

Estimated time:
Found in version:
11.2
Fixed in version:
11.3
Platforms:

Description

I managed to compile/install the SaxonC 11.1 PHP extension for PHP 7 under Ubuntu 20.04 but when trying to run the provided xpath and xquery sample (i.e. xpathExamples.php and xqueryExamples.php) I find they fail because the created query directory they try to load their data or code from is empty.

I fixed that by downloading files from https://saxonica.plan.io/projects/saxonmirrorhe/repository/he/revisions/saxon11/show/src/main/c/samples/php/query but I guess the build/package system doesn't include those files in the zip provided for Linux https://www.saxonica.com/download/libsaxon-HEC-setup64-v11.1.zip as there the query directory is indeed empty.

Actions #1

Updated by O'Neil Delpratt about 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 100
  • Found in version set to 11.2

I have committed a fix for this bug in the build script. Testing required

Actions #2

Updated by O'Neil Delpratt about 2 years ago

  • Status changed from In Progress to Resolved

Confirmed fixed in build script.

Actions #3

Updated by O'Neil Delpratt almost 2 years ago

  • Status changed from Resolved to Closed
  • Fixed in version set to 11.3

Bug fix applied in the SaxonC 11.3 maintenance release.

Please register to edit this issue

Also available in: Atom PDF