Project

Profile

Help

Bug #5404

closed

Configuration properties not set on SaxonProcessor

Added by O'Neil Delpratt almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Python
Start date:
2022-03-17
Due date:
% Done:

100%

Estimated time:
Found in version:
11.2
Fixed in version:
11.3
Platforms:

Description

I tried to set the location of the license based using the configuration property on the SaxonProcessor but this fails to work.

See example code below:

from saxonc import *

with PySaxonProcessor(license=True) as saxonproc2:
    saxonproc2.set_configuration_property('http://saxon.sf.net/feature/licenseFileLocation', '/location/saxon-license.lic')
    trans = saxonproc2.new_xslt30_processor()

    executable = trans.compile_stylesheet(stylesheet_file='exampleEE.xsl')
    if executable is None:
       exit()
    executable.set_property("!omit-xml-declaration", "yes")
    sw = executable.call_template_returning_string("main")
    print("Result=",sw)
Actions #1

Updated by O'Neil Delpratt almost 2 years ago

  • Description updated (diff)
  • Category changed from C++ API to Python
Actions #2

Updated by O'Neil Delpratt almost 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

The PySaxonProcessor.set_configuration_property method in the in the Python API has variable typo which causes the configuration property failure.

Now fixed and available for the next maintenance release.

Actions #3

Updated by O'Neil Delpratt almost 2 years ago

  • Status changed from Resolved to Closed
  • Fixed in version set to 11.3

Bug fix applied in the SaxonC 11.3 maintenance release.

Please register to edit this issue

Also available in: Atom PDF