Project

Profile

Help

Bug #5995

closed

Javadoc for XPathCompiler.setLanguageVersion should mention 4.0 is accepted

Added by Debbie Lockett 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
Documentation
Sprint/Milestone:
-
Start date:
2023-04-26
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
11, 12, trunk
Fix Committed on Branch:
11, 12, trunk
Fixed in Maintenance Release:
Platforms:

Description

As raised by Martin Honnen in a forum topic (https://saxonica.plan.io/boards/3/topics/9383):

For XQuery, the API documentation https://www.saxonica.com/html/documentation12/javadoc/net/sf/saxon/s9api/XQueryCompiler.html#setLanguageVersion(java.lang.String) documents that possible versions are "version - "3.1" or "4.0" in the current Saxon release.".

For XPath, the API documentation https://www.saxonica.com/html/documentation12/javadoc/net/sf/saxon/s9api/XPathCompiler.html#setLanguageVersion(java.lang.String) only mentions "value - One of the values 1.0, 2.0, 3.0, 3.05, 3.1.".

But XPath 4.0 is supported from Saxon 11, so the documentation for XPathCompiler.setLanguageVersion should be corrected.

Please register to edit this issue

Also available in: Atom PDF