Project

Profile

Help

Bug #2464

closed

xsl:output method 'html' and DOCTYPE decl problem in s9api

Added by O'Neil Delpratt over 6 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Category:
s9api API
Sprint/Milestone:
-
Start date:
2015-10-06
Due date:
% Done:

0%

Estimated time:
Legacy ID:
Applies to branch:
Fix Committed on Branch:
Fixed in Maintenance Release:
Platforms:

Description

Reported by user:

We found a problem when generating html files on .NET API.

We need HTML 5 doctype () in the transformation output and we tried to use xsl:output (see below) for that:

<xsl:output method="html" version="5.0" encoding="UTF-8" indent="yes" doctype-public="html" />

It works fine with c:\Program Files\Saxonica\SaxonEE9.6N\bin\Transform.exe – i can see in the output.

But it doesn’t work when using .NET API.


Related issues

Is duplicate of Saxon - Bug #2296: Serializer.SetOutputWriter seems to ignore omit-xml-declaration setting [Saxon-HE 9.6.0.4N]ClosedO'Neil Delpratt2015-01-20

Actions

Please register to edit this issue

Also available in: Atom PDF