Project

Profile

Help

Support #2625

Saxon-HEC installation problem in Centos 6.7 32 bit

Added by Duygu Colak over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
High
Category:
PHP API
Start date:
2016-02-18
Due date:
% Done:

100%

Estimated time:
Found in version:
1.0.0

Description

Although I have successfully installed Saxon-HE/C v.0.3.1 to my Windows 8 machine, I couldn't manage to install Saxon-HE/C v 1.0.0 or Saxon-HE/C v.0.3.1 on my Centos 6.7(32 bit) machine. My Apache version is 2.2.15 and Php version is 5.4.45 on Centos. Java jdk version is 1.6.0.

I have downloaded the install.sh example from Petr Zak, and updated it to fit my environment, but I keep getting error while installing, especially when I run make command. You may find my version of install.sh and output file of installation process.

When I run "make" command, it gives errors, you may find this error file named as "make_output.txt" file in the attachments.

Thanks for your help in advance.

Best Regards

install.sh (4.29 KB) install.sh Duygu Colak, 2016-02-18 12:31
make_output.txt (7.13 KB) make_output.txt Duygu Colak, 2016-02-18 12:31
output_installsh.txt (20.8 KB) output_installsh.txt Duygu Colak, 2016-02-18 12:46
XdmValue.h (3.44 KB) XdmValue.h Duygu Colak, 2016-02-23 08:34
output_installsh.txt (24.8 KB) output_installsh.txt Duygu Colak, 2016-02-23 08:35
XdmNode.h (2.47 KB) XdmNode.h Duygu Colak, 2016-02-23 10:01
XdmValue.h (5.36 KB) XdmValue.h Duygu Colak, 2016-02-23 10:01
output_installsh.txt (39.6 KB) output_installsh.txt Duygu Colak, 2016-02-23 10:01
install.sh (4.29 KB) install.sh Duygu Colak, 2016-02-23 10:04
saxon.so (1.71 MB) saxon.so O'Neil Delpratt, 2016-02-23 17:15

History

#1 Updated by Duygu Colak over 4 years ago

You may also find install.sh command output file.

#2 Updated by O'Neil Delpratt over 4 years ago

  • Category set to PHP API
  • Status changed from New to In Progress
  • Assignee set to O'Neil Delpratt

Thanks for reporting the problem you have found. Investigating it now.

#3 Updated by O'Neil Delpratt over 4 years ago

Update:

I am still investigating your build problem on the centos 6.7. However I am hitting the jni.h not found error. Not sure why though as I think I have linked the jni header file correctly.

#4 Updated by Duygu Colak over 4 years ago

Thank you so much for your time, I am looking forward for your answer. If you need more information, I would like to answer.

#5 Updated by O'Neil Delpratt over 4 years ago

  • Found in version set to 1.0.0

HI, I have managed to build Saxon/C for C++ and on PHP on Centos 6.7. I simply copied the jni.h and the jni_md.h to /usr/include to overcome the jni issue. There were a couple more issues that I found:

  1. C++ build fails under some compilers due to the variable valueType being initialized as NULL. I filed this as a bug: https://saxonica.plan.io/issues/2636

Workaround is to remove the NULL assignments in the file XdmValue.h and XdmNode.h

  1. The config.m4 file seems to assume the library name libsaoxn.so under /usr/lib. In Saxon 1.0.0 we have renamed the library to libsaxonhec.so for HE and similar naming for PE and EE. The workaround is to create symblic link of the library libsaxonhec.so to libsaoxn.so under '/usr/lib'. see bug: https://saxonica.plan.io/issues/2637

The errors I see in your log files are somewhat different to the errors I found. I suggest following points 1) and 2) then try to build Saxon/C on C++ with the test harnesses in the folder 'samples/cppTests'. If that is successful then the problem is with PHP.

Let us know how you get on

#6 Updated by O'Neil Delpratt over 4 years ago

  • Status changed from In Progress to AwaitingInfo

#7 Updated by Duygu Colak over 4 years ago

I have tried what you said,

  1. I copied jni.h and jni_md.h files to /usr/include even though I didn't have jni issue.

  2. I couldn't find XdmNode.h file but I tried to remove the Null assignments from the file XdmValue.h by commenting the lines between 31 to 33. I guess this is the wrong approach to remove null assignments, could you tell me how can I remove them?

  3. I did exactly what you said in number 2.

I tried once again the build command, and it gave the output file in the attachment.

#8 Updated by Duygu Colak over 4 years ago

And I don't have 'samples/cppTests' folder under my Saxonica folder.

#9 Updated by O'Neil Delpratt over 4 years ago

Go one level down again.

#10 Updated by O'Neil Delpratt over 4 years ago

From what you have said in comment 7 it looks like you don't have Saxon/C 1.0.0 installed or have the full download. Because if you cannot find XdmNode then that is the version 0.3.1.

#11 Updated by Duygu Colak over 4 years ago

I have all two versions downloaded and been trying on both of them. Now I will download 1.0.0 version again and we can continue on the same version.

#12 Updated by Duygu Colak over 4 years ago

I have downloaded Saxon/C 1.0.0 in /usr/lib/Saxonica folder,

Changed null assignments in XdmValue.h and XdmNode.h files.

Created symblic link of libsaxonhec.so to libsaoxn.so under '/usr/lib'.

And run my install.sh file. You can find the output in the attachment, nothing's changed.

#13 Updated by Duygu Colak over 4 years ago

How can I build Saxon/C on C++ with the test harnesses in the folder 'samples/cppTests'. I know very little about C++.

#14 Updated by O'Neil Delpratt over 4 years ago

You will need to execute the build script in the cppTests folder.

You might have to make the file an executable by running the following command:

chmod +x buildhec.sh

Then execute the build script from your terminal:

./buildhec.sh

At this stage you should see three executable files created: testXPath, testXSLT, testValidator and testXQuery

You can try executing any of them. i.e. ./testXPath

If you get errors at this stage please send them to my email and I will try to correspond with you off the bug tracker:

#15 Updated by Duygu Colak over 4 years ago

Yes I get errors, I am sending an email to you.

Thank you so much.

#16 Updated by O'Neil Delpratt over 4 years ago

  • File saxon.so saxon.so added
  • Status changed from AwaitingInfo to Rejected
  • % Done changed from 0 to 100

Investigated the problems further off the bug tracker site. The issue was the PHP 5.3 installed as default from the terminal, this was in conflict with the PHP 5.4 running from the web server.

I have attached the PHP 5.4 php library module built on the centos machine.

Please register to edit this issue

Also available in: Atom PDF